What is the best way to test a pdl

Homepage Clovertech Forums Read Only Archives Cloverleaf Cloverleaf What is the best way to test a pdl

  • Creator
  • #50871
    Gina Borden

    I have an interface that is sending the correct beginning and ending message characters, however, they are also sending a 00 (null) after the ending characters.

    I was going to modify the pdl, but wanted to be able to test it before putting it in production, as this is a Live system.  What is the best way to test a pdl?

    This is just writing an error in my error log, and they have had a few days of dumping messages, and filling up the error log which then shuts down the interface.  I think if I can correct this error, it might solve the issue of the interface shutting down.



Viewing 3 reply threads
  • Author
    • #67859
      Jim Kosloskey


      Before modifying a PDL, have you tried to get the sender to correct what is obviously an error?

      email: jim.kosloskey@jim-kosloskey.com

    • #67860
      Gina Borden

      Yes, I have asked them to remove the null, but they claim they are not sending it, and have no way to remove it.  Believe me I have tried.

    • #67861
      Robert Milfajt

      I find this interesting.  I thought the purpose of the MLLP protocol was to use a start characater (x0b) and end sequnce (x1c x0d) to signify the end of the message.  My impression was anything before the x0b and after the x1cx0d should be ignored.  Does this mean the standard PDL is not working correctly?

      Back in the day, I had a problem exactly like this with a Materials Management system from a company called Nova, and we ended up doing exactly what Gina suggested and creating a new PDL.

      Hope this helps,

      Robert Milfajt
      Northwestern Medicine
      Chicago, IL

    • #67862
      Gina Borden

      I suppose I could be getting this error for other reasons, but this is what I found.  If you know of another reason why I would be getting this no-match error, I would appreciate it.  Below is what I sent to the vendor:

      <span style="color: red]I have been looking at my logs from the mik (I keep 1 weeks worth), and I have a lot of errors”>

      <span style="color: blue](excerpts from my log)[/color]05/12/2009 15″> no-match: no more phrases to try

      In my mlp_tcp.pdl, I look for for the start of the message:

      <span style="color: blue](excerpts from my log)[/color] [pdl “>  0b4d 53 48  7c 5e 7e 5c  |.MSH|^~|

      And I look for to end the message:

      <span style="color: blue](excerpts from my log)[[/color]pdl “>  75 74 65 73  0d 1c 0d00  |utes….|

      However, the messages from the MIK come with a which is a null after the .

      This isn’t stopping the messages from processing, however I can see where after numerous errors that the process might shutdown if the error log became too big.  This could explain why we are only seeing the apsmik process being affected by this.  

      Of course, the best resolution to me is that GE would modify their message to meet MLP standards and remove the null that is coming at the end of the message.  If that isn’t possible, I will contact the cloverleaf forum to see if I can modify my .pdl to accept the null.

Viewing 3 reply threads
  • The forum ‘Cloverleaf’ is closed to new topics and replies.

Forum Statistics

Registered Users
Topic Tags