unknown segment

  • Creator
    Topic
  • #50744
    Mike Delahunt
    Participant

    Hello All,

    (we are running cloverleaf version 5.5)

    I am building an new interface where the inbound thread is setup with a Trx id Format of ‘HL7’.  I also created a new variant because the sending application is sending multiple Z segment.  When I turn the interface on and view the process level error log I am recieving the following errors:

    msg :RecP:WARN/0:rev_fsl_adt_ib:03/24/2009 09:35:33] [0.0.3] unknown segment ‘ZE1’ — ignored.

    [msg :RecP:WARN/0:rev_fsl_adt_ib:03/24/2009 09:35:33] [0.0.3] unknown segment ‘ZE2’ — ignored.

    These segment are properly created in the variant but the Trx id setting on the inbound thread does not allow me to define which variant I want to use.  Could someone tell me what I’m missing?

    Thanks in advance!

    Mike

Viewing 3 reply threads
  • Author
    Replies
    • #67333
      Anonymous
      Participant

      The place where these needs to be defined is in your Translation file.

      First take the message into the tester using your Variant to make sure that works. Then run it through the translation test.

      If you don’t get the errors there then you will not get them in the engine.

      Make sure when you define your translation to use your new variant.

    • #67334
      Mike Delahunt
      Participant

      Hello John,

      I ran both the variant and the xlate in the tester using the inbound message and both worked with no errors.  I shutdown the site and performed a site clean up, started everything back up and the errors still show up in the process error log.  Any other idea’s?  I can send print screen if that would help.  I must be missing something simple.

      Thanks again,

      Mike

    • #67335

      Those errors are generated by the xlate (not trx). Make sure you have configured the xlate to use the variant you created (the one that includes the Z segments).

      Note that by default trx pulls the value from MSH.09 and uses that value to determine the routes. It pretty much ignores the rest of the message.

      -- Max Drown (Infor)

    • #67336
      Mike Delahunt
      Participant

      I want to thank all of you that replied to my dilemma!!  We have a create_ack tcl proc on our inbound tps that requires arguments to define what variant you want to use.  Once I put in the correct variant the errors went away, I knew it had to be something simple.  Thanks again, you guys/gals are the best!

      Mike

Viewing 3 reply threads
  • The forum ‘Cloverleaf’ is closed to new topics and replies.

Forum Statistics

Registered Users
5,053
Forums
28
Topics
9,236
Replies
34,175
Topic Tags
273