Tcl Callout error (302)

Homepage Clovertech Forums Read Only Archives Cloverleaf Cloverleaf Tcl Callout error (302)

  • Creator
  • #50817
    Gena Gill

    I have a system getting an error that says:

    msgType           : DATA

       msgClass          : ENGINE

       msgState          : Tcl callout error (302)

       msgPriority       : 5120

    What does this Tcl callout error mean?  I think that the TCL proc that is the problem is one where I’m copying PID18 to PID18, with TCL in the middle to append zeros to the front of the encounter number until the total number of characters equals 11.  However, I’m using this proc successfully elsewhere in live and in test, so I dont’ know what the problem could be.

    Of note is that this did work.  I looked in my SMAT file and do see the zeros did append properly.  Here is what i’m using to append the zeros:

    set tmp [format “%11s” [lindex $xlateInVals 0]]

    set xlateOutVals

      The only other unusual thing I have is a TCL proc on the thread that I use to throttle the messages by 30 seconds.  That’s worked properly for months.

      Any ideas?

Viewing 6 reply threads
  • Author
    • #67661

      I think you see that error when Cloverleaf dumps a message to the error db? Try doing a search for that error on the forums.

      -- Max Drown (Infor)

    • #67662
      Gena Gill

      Yes, that’s where I’m seeing the error.  I tried searching the forum with no luck.  I’ve just not seen that error before and need to figure out what it is so I can correct it.

    • #67663
      Keith McLeod

      Go to the error database.  Get the message ID.

      Then run the following:

      hcidbdump -e -m -c | pg

      This will ususally show you more detail on the error like what line of code it errored at….Hope this helps.  Depending on your version of Cloverleaf, the message id may be either 0.0.99999999 or you mught need to drop the 0.0. from the id….

    • #67664
      David Barr

      Look in the process log file for the process that contains the thread that was processing this message.  You’ll probably see a more detailed TCL error.

    • #67665

      Try checking to see if any of your procs are setting the messasge disposition to ERROR.

      Also, make sure you are handling your ACKs with a proc (we usually use hcitpsmsgkill).

      -- Max Drown (Infor)

    • #67666
      Jim Kosloskey


      You should see additional information regarding the Tcl callout error in the process or error log.

      Hopefully that will give you sufficient information (along with analyzing the proc itself).


    • #67667
      Gena Gill

      I think the problem is solved.

      The problem was with the proc I was using to append zeros to the number in PID18.  I compiled the translation several times, and bounced the process several times, with no luck.  Finally, I copied the proc, deleted it, saved the translation, compiled it, bounced the process, then put the proc back, saved, compiled, and bounced yet again.

      I’ve not gotten the error since.  No clue why I had to go through all that, but it worked.

Viewing 6 reply threads
  • The forum ‘Cloverleaf’ is closed to new topics and replies.

Forum Statistics

Registered Users
Topic Tags