Preserving nl message separator

Homepage Clovertech Forums Read Only Archives Cloverleaf Cloverleaf Preserving nl message separator

  • Creator
  • #49674
    Jay Yeiser

    Unable to preserve carriage return line feed as message separator when doing FTP file transfer from Windows to Unix where Cloverleaf resides.  I use file protocol for the interface pulling the file and the file does not find the carriage return line feed separating the messages.  I have made sure FTP is set to binary.  I inserted hex 0d for segment separator and hex 0d0a message separator in UltraEdit and then saved.  I then transferred using Reflections and ensured transfer type set to binary.  This used to work on an old version of UltraEdit and Reflections.

Viewing 0 reply threads
  • Author
    • #63054
      Russ Ross


      Sounds like you understand the challenge since you are aware you need to FTP in binary mode to keep the CR-NL in a DOS file being moved to UNIX.

      hcihd is also a good command to confirm what you think you see is really true and it will display the contents of the file on your UNIX server in an ASCII/HEX type dump.

      You said the older version of Ultra-Edit worked so check your newer version of the Ultra-Edit file handling configurations to make sure Ultra-Edit is not being too smart.

      Another thing to be aware of is that Ultra-Edit can FTP edit and save files directly on your UNIX server (File -> FTP -> open or save).

      I think this is one of the strongest features of Ultra-Edit.

      One time I had a vendor using Ultra-Edit on my Windows PC to simultaneously edit/copy/paste

      – a TCL proc on his server in Berkley, California

      – another file in Canada

      – a file on my Cloverleaf UNIX server in Houston, TX

      – local DOS text files on my PC

      – an EBCDIC file on a mainframe

      and make it seem as if all the files are DOS text files on my Windos desktop.

      I origanlly got Ultra-Edit because of this feature so new hires did not have to learn vi right away and could be productive quicker.

      The preference setting I look for in Ultra-Edit to stay out of the type of trouble you are describing is to make sure I check the box in the screen shot below that says

      “Save file as input format”

      Russ Ross

Viewing 0 reply threads
  • The forum ‘Cloverleaf’ is closed to new topics and replies.

Forum Statistics

Registered Users
Topic Tags