Multiple email addresses in Alert configuration

Homepage Clovertech Forums Read Only Archives Cloverleaf Cloverleaf Multiple email addresses in Alert configuration

  • Creator
  • #51081
    Mike Campbell

    Sorry for the newbie question, but I am trying to setup alerts in 5.7 to send to multiple email addresses.  Seems everything I have tried only sends to the first address.  I have enclosed all address withing double quotes:

    “address_1 address_2”, separated with a comma and a semi-colon, and done the same without the double quotes.  

    I’ve search the documentation and the forums and didn’t find anything.


    Mike Campbell

Viewing 16 reply threads
  • Author
    • #68710

      Maybe you could set up an email group to send to?

      -- Max Drown (Infor)

    • #68711
      David Barr

      Are you using exec to call mailx?

      It might help if you post the line from $HCISITEDIR/Alerts/default.alrt that you are trying to get working.

    • #68712
      Mike Campbell

      The line in the alert is:

      : Action: hcialert2email  -TO, -SUBJ “Test e-mail and page alert” -MSG defaultTest_Alert-07969.msg -FROM mike.campbell@nm -SERVER localhost -PORT 25

      We are doing this out of the alert config. and not in a proc or script.

    • #68713
      Keith McLeod

      Just a suggestion if you are using UNIX of some flavor, how about defining an alias for you email groups.

      In the hci home directory create a ‘.mailrc’ file and add in your alias lines.

      alias address.domain,address.domain

      use your somegroup_mail alias for the address.  If you create other alerts that need this group, you can modify the list in the hci home/hci/.mailrc file instead of every alert.

      Verify the alias syntax for your use.  The comma separator has worked for me.

      example: mail -s “Subject here” somegroup_mail < (file for message body)

    • #68714
      Keith McLeod

      Have not sent out mail from 5.7 yet, however the alias route may still be an alternative.  Did you try a semi colon?

    • #68715
      David Barr

      I think that “hcialert2email” must be a script that is unique to your site.  You need to look at that script to see how it is processing the -TO argument in order to fix this.  If you post the script, we can help take a look.  You can type “type hcialert2email” or “which hcialert2email” from the command line if you want to figure out where the script is located on your system.

      You should be able to run this command from the command line to test changes that you are making without triggering the alert.

      Have you tried this? -TO -TO

      (listing the -TO argument twice)

    • #68716
      Mike Campbell

      I have tried the semi-colon to no avail.  I would imagine that somewhere inside this code the secret handshake resides:


      # main – Main routine for hciguimsg

      proc main argv {

             set optargs

               if { [catch {set args [getopt $argv $optargs]} err] } {

                       echo $err

                       exit 64


               if { $FROM == “” } { set FROM “” }

               if { $NAME == “” } { set NAME “” }

               if { $PASS == “” } { set PASS “” }

               if { $SERVER == “” } { set SERVER “localhost” }

               if { $PORT == “” } { set PORT “25” }

               SendEmailAsAlert $TO $MSG $SUBJ $FROM $NAME $PASS $SERVER $PORT

               #echo $MSG

               file delete $MSG

               exit 0

      1. #68717
        Mike Campbell

        I did try adding extra -TO to the alert, and that didn’t work.  No emails were generated when that was in the alert setup.

      2. #68718
        Jim Kosloskey


        I am guessing SendEmailAsAlert is the proc where the actual emailing is done.

        I would try to look in there to see what it is doing.

        Have you contacted support?


      3. #68719
        Mike Campbell

        I’ve held off contacting support until I posted it out here.  That is my next option, probably tomorrow.  Thanks all for the great ideas.  I’ll be sure to post the solution out here for future reference!

      4. #68720
        Michael Lacriola

        Here’s an example of an action within an alert. This works with no issues. We are Unix here.

        mail -s “Please reset rls thread in Epic Site – Error state”, </quovadx/messages/camefrom.msg

        This should be read as all one line. -s defines the subject. The text of the message is within file /quovadx/messages/camefrom.msg that we define.

      5. #68721
        Jim Kosloskey


        It sounds like Cloverleaf(R) 5.7 has the ability internally to specify email right from the new Alerts configurator.

        This is something new and as such I think support needs to be involved.

        I don’t think there are that many of us on 5.7 yet and of those apparently few (maybe you are the only one) have tried this new feature for multiple destinations.


      6. #68722
        Mike Campbell

        Well…somebody has to be the first!!

        Again, thanks to all for the tips.  I’ll let you know what the Cloverleaf folks say.

      7. #68723
        John Mercogliano


         It looks like you have a space after the comma.  The mime and smpt packages don’t like white spaces in the header statements unless you have physicially delimited everything with quotes.  Try making your address list one long comma seperated list with no spaces.

         I was able to manually run the SendEmailAsAlert proc with multiple addresses that way.  I could not run the proceedure as a standalone though.  Trying to figure that out. Just loaded 5.7 though 🙂

        John Mercogliano
        Sentara Healthcare
        Hampton Roads, VA

      8. #68724
        Mike Campbell

        I’ve tried with and without a space after the comma.

      9. #68725
        Mike Campbell

        Well, guess I must have been smoking something.  Entering multiple addresses separated by a comma and NO SPACE did the trick.  I swear I tried that!  

         It is working now…so thanks again to all for the great ideas.  


      10. #68726
        Brent Fenderson

        In order to get mutiple go tos in the alerts you have to enclose them in double quotes and separate them with a comma.

        This is a windows problem that is leaving the comma out when the alert is fired.



    Viewing 16 reply threads
    • The forum ‘Cloverleaf’ is closed to new topics and replies.

    Forum Statistics

    Registered Users
    Topic Tags