GMT time displayed on a single client machine

Homepage Clovertech Forums Read Only Archives Cloverleaf Cloverleaf GMT time displayed on a single client machine

  • Creator
  • #50414
    John Zalesak

    I am having a problem on my client PC. (XP SP3) The engine is running on a UNIX box.  

    My PC and the UNIX box are showing the time as EDT.  All the translates and messages have the time in the correct time zone.

    BUT when I load a SMAT file, the date/time stamp in the file list is GMT and when I am viewing the message the sending time is displayed as GMT.  

    I guess my question is how do you set the time zone for the SMAT viewer??

    Any help is greatly appreciated.

Viewing 7 reply threads
  • Author
    • #66029
      Mike Wilson

      Im having the same problem, Unfortunately I have not found a solution yet.  My server and PC have the correct time but when I view SMAT files or just look at a thread it shows the GMT time.  Confusing.

    • #66030
      John Zalesak

      I have opened  a case to get this resolved.

      I will let them know you have the same issue.

      When it gets resolved, I will let you know.

    • #66031
      John Zalesak

      Turns out that I am running SP3 and the other two client machines here are running SP2.

      I have the issue and the other two do not.

      I do not know if this is it.  Is anyone else running XP SP3?  Could you check you times in SMAT for me???


    • #66032
      Jim Kosloskey


      I am running the IDE on SP3 for CL 5.2 and I do not see GMT time on SMAT (IDE not Xterm). I see EDT and EST at the appropriate dates.

      Could there be a client.ini setting that is affecting your display?

      I am assuming both you and the others that do not have GMT dates showing are referencing the same SMAT files.

      Have you posed the question to support?


    • #66033
      John Zalesak

      Yes I have – Case 38729

      Just tyring to either solve it on our own or provide as much info as possible.

      Thanks !

    • #66034
      John Zalesak

      Per the .ini file

      We copied the file from a working client station and it did not help my machine.

      The entire thing is rather odd and very confusing to find the data you want.

      Thanks Again

    • #66035
      John Zalesak

      This has just been resolved by Healtvisions.

      Not sure what was wrong.

      Just for info, my client machine is running XP ver 5.1 SP3

      The text below is copied from a Healthvision Support E-mail.

      The issue might be related to a bug in JRE1.4.2  (

      Here is the workaround,


      1) Backup the file client.ini in the folder “%HCIROOT%client” in the client machine.  

      2) Open IDE, click menu “Options->Client Options …”, it will open a “Client Preferences” dialog, click “Advanced” tab,

      Enter the following string in the JVM Arguments field,  


      Clicking “Ok” button to close the dialog “Client Preferences”, and restart IDE.

      Now try to load message in SMAT and see if Sending date is displayed correctly. (Timezone should be displayed as “EDT” instead of “GMT”)  

    • #66036
      Mike Wilson

      Great news!  way to hunt down that resolution John.  It was becoming a pain in the but to see the wrong time.  Thanks again.

Viewing 7 reply threads
  • The forum ‘Cloverleaf’ is closed to new topics and replies.

Forum Statistics

Registered Users
Topic Tags