fileset-local thread advanced timer

Homepage Clovertech Forums Read Only Archives Cloverleaf Cloverleaf fileset-local thread advanced timer

  • Creator
  • #49568
    Barb Dozier

    We have just gone up with a new meditech install and all the interfaces related to it.  We have a fileset-local thread configured to deal with a Mat Man charge file that comes in as a fixed length flat file.  We have the advanced timer configured to parse the directory based on the attached schedule.  The input file gets dropped off about 00:01 with the resulting output file to be moved over to meditech by 1am.  It appears though that the scheduler is skipping the midnight hour after the day rolls over.  Please see a section of log file that is in the attachment as well.  Does this sound right?  I wouldn’t think we should have to specifically reference the midnight hour as we have * in all schedule paramters other than second.  We are going to play with more specific schedules but thought I would throw it out to this group as it seemed odd to me.

    Thanks, Barb

Viewing 4 reply threads
  • Author
    • #62507
      Russ Ross

      I would be scratching my head and rubbing my eyes, too.

      I’m grasping at straws but how about trying to explicitly specifiy the hours and see if that makes it work.

      For example:

      Hours: 00-23


      Hours: 00,01,02,03,04,05,06,07,08,09,10,11,12,13,14,15,16,17,18,19,20,21,22,23

      Also make sure there are no hidden characters after the end of each line.

      I know these are pretty weak suggestions but maybe you will get lucky.

      Russ Ross

    • #62508
      Barb Dozier

      Thanks for the ideas.  We ended up going that direction and it seems to be working just fine.  The file only shows up within the midnight hour so we specifically defined 00 and went for every 5 minutes – 05,10,15, etc.


    • #62509
      Chris Williams

      From looking at the screen capture in your message you have it scheduled to run every day, every hour, every minute at 30 seconds into each minute. It sounds as though you really only need it to run only once each day just prior to 1am.

    • #62510
      Chris Williams


      Both forms are correct. You can also combine them, e.g., “8-12, 14, 16-20”.

      Where I had problems was not remembering that the spec was for the entire hour. I wanted my pager to go off between 8a and 5p. The spec needed to be “8-16” rather than “8-17” because 16 included up to 16:59:59.

    • #62511
      Russ Ross


      I fell into the same trap long ago before I became enlightened as you have.

      It made sense when I figured it out but tricked me at first, too.

      Now I understand the hour setting needs to be one hour less than the end time desired since the * for minutes will keep it going for an extra 59 minutes.

      Russ Ross

Viewing 4 reply threads
  • The forum ‘Cloverleaf’ is closed to new topics and replies.

Forum Statistics

Registered Users
Topic Tags