Connection refused: connect

Homepage Clovertech Forums Read Only Archives Cloverleaf Cloverleaf Connection refused: connect

  • Creator
  • #50512
    Michael Stankov

    Hi all,

    I use Cloverleaf on a VMWARE for test and for some odd reason I can’t open the network monitor anymore. I get an exception error with this error text:


    Connection refused: connect Connection refused: connect

       at Method)

       at Source)

       at Source)

       at Source)

       at Source)

       at Source)

       at com.hie.cloverleaf.gui.netmon.MonitorDServer.connectAndInitReader(

       at com.hie.cloverleaf.gui.netmon.MonitorDServer.startMonitorDaemon(

       at com.hie.cloverleaf.gui.netmon.MonitorDServer.(

       at com.hie.cloverleaf.gui.netmon.NetMonPanel.jbInit(

       at com.hie.cloverleaf.gui.netmon.NetMonPanel.(

       at com.hie.cloverleaf.gui.netmon.NetMonTool.jbInit(

       at com.hie.cloverleaf.gui.netmon.NetMonTool.(

       at java.lang.reflect.Constructor.newInstance(Native Method)

       at com.hie.cloverleaf.gui.launchpad.LaunchpadPanel.startTool(

       at com.hie.cloverleaf.gui.launchpad.LaunchpadPanel$8.actionPerformed(

       at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)

       at javax.swing.AbstractButton$ForwardActionEvents.actionPerformed(Unknown Source)

       at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)

       at javax.swing.DefaultButtonModel.setPressed(Unknown Source)

       at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)

       at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)

       at java.awt.Component.processMouseEvent(Unknown Source)

       at java.awt.Component.processEvent(Unknown Source)

       at java.awt.Container.processEvent(Unknown Source)

       at java.awt.Component.dispatchEventImpl(Unknown Source)

       at java.awt.Container.dispatchEventImpl(Unknown Source)

       at java.awt.Component.dispatchEvent(Unknown Source)

       at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)

       at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)

       at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)

       at java.awt.Container.dispatchEventImpl(Unknown Source)

       at java.awt.Window.dispatchEventImpl(Unknown Source)

       at java.awt.Component.dispatchEvent(Unknown Source)

       at java.awt.EventQueue.dispatchEvent(Unknown Source)

       at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)

       at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)

       at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

       at Source)

    Thankfull for any hits!


Viewing 7 reply threads
  • Author
    • #66406
      Michael Hertel

      Is the hostserver running in that environment?

    • #66407
      Michael Stankov


      How can I check that??

    • #66408
      Gary Atkinson

      Run hciss

    • #66409
      Michael Stankov

      Hi, it seems to be running.

      Host Server is running, PID = 132

    • #66410
      Michael Stankov

      Something more I could check?

    • #66411
      Michael Hertel

      I don’t have experience with VMWARE nor windows version of Cloverleaf.

      But this may not be related to either of those two things.

      Could you post a picture of the error you are getting?

      I’d like to see where in your flow this is happening.

    • #66412
      John Mercogliano

      A few things you can try.

      1. Stop and start the hostserver

      2. Determine what site the gui is trying to open by default.  When the GUI first starts it tries to open the last site you where in and if the monitord is not running it tries to start it.  Possibly something wrong with the site.

      You have not said if you are running the GUI from windows to connect to the server or directly from the server.  If you are connecting from the windows GUI find out if your network security is locking down access through the vpn firewall.  The might need to have them add the server ip address and ports to the access list.  For the ports you will need to provide them are the host server port which will depend on the version you are running and the ephemeral range for your server.  We had a similiar problem when our security folks decided to go with juniper and lock everything down.

      Hope this helps.

      John Mercogliano
      Sentara Healthcare
      Hampton Roads, VA

    • #66413
      Andy Devitt

      I ran into this problem on one of my servers today, I run AIX. I had to install the  bos.adt.debug package to resolve, I had it on one test server, but not the other.

      I am not sure if this is the same issue that all are having and I know this post is a bit old, but it seems to be related to the PTools Library for AIX. I believe it would have been in the libptools_ptr.a patch of versions prior to AIX 6.1

Viewing 7 reply threads
  • The forum ‘Cloverleaf’ is closed to new topics and replies.

Forum Statistics

Registered Users
Topic Tags