CL5.6 on AIX5.2(8)

Homepage Clovertech Forums Read Only Archives Cloverleaf Cloverleaf CL5.6 on AIX5.2(8)

  • Creator
  • #50208
    Dee Davis

    Just wondering if when anyone has worked with commands at the AIX prompt if there are problems returning from the scripts.  Example, if we run “hcienginestop -p ” we can wait for up to 3 minutes after “Process ‘process’ is not running” to return to the prompt.  Also, when we were bringing up processes, it took a long time for connections to come up.  We saw this in the process log … notice theime between the Engine process and the “Msg space limit”…

    [[prod:prod:INFO/0:  STARTUP_TID:07/24/2008 15:18:51] Engine process is 93198 on host mchsie5

    [prod:prod:INFO/1:adt_misc5_cmd:07/24/2008 16:07:39] Msg space limit is 0

    This is the first attempt to bring up on this box.  We run CL5.3 on the same box.  We brought all processes and site daemons down on that root and still see the issue.

    Any thoughts?


    Dee Davis

    Moses Cone Health System

Viewing 5 reply threads
  • Author
    • #65215
      Charlie Bursell

      I don’t know about the slowness in starting up but would suspect network problems.  As ffor the shutdown, you may be because of the script.  It has finally been changed but in previous versions hcienginestop could take up to 5 minutes to stop a hung process.

      Edit the script ($HCIROOT/bin/hcienginestop) and look for the following subroutine:

      sub waitForIt {

         local( $name ) = @_;

         local( $tries ) = 30;

         while( ($pid = &getHciEnginePid( $name )) && $tries– ) {

             sleep 10;


         return $pid;


      You will notice that it can go through the loop 30 times sleeping 10 seconds each time.  30 x 10 = 300 seconds = 5 minutes

      Change the 30 to 6.  All veersions since 5.4 (I think) already have this change.  If it is already set to 6, your problem is elsewhere.

    • #65216
      Dee Davis

      Hi, Charlie ..

      This is really strange.  There are no delays on our 5.3 root.  We took everything down in 5.6 (very painful) and stopped daemons. This morning we stopped and restarted the host server.  Started the Site Daemons.  We cannot get a response to hciprocstatus (it timed out). Looked in the hcimonitord log; it looks now like it took 4 minutes to do get past the pid number:

      [prod:prod:INFO/0:  STARTUP_TID:07/25/2008 09:23:52] Monitord process is 57228 on host mchsie5

      [prod:prod:INFO/0:  hcimonitord:07/25/2008 09:27:38] Applying EO config: ”

      On same box .. came up immedicately in 5.3 — but there are no timestamps; I just started and went to the log:

      [prod:prod:INFO/0:  STARTUP_TID] Started at Fri Jul 25 09:34:47 2008

      [prod:prod:INFO/0:  STARTUP_TID] Monitord process is 71636 on host mchsie5

      [prod:prod:INFO/0:  hcimonitord] Applying EO config: ”

      I am unsure as to what to look at… Thanks for picking this up.


    • #65217
      Dee Davis

      One more example — same box — all through command line to avoid client connectivity:

      Started process in 5.6:

      [prod:prod:INFO/0:  STARTUP_TID:07/25/2008 09:37:52] CLOVERLEAF(R) Integration Services 5.6P Rev1

      [prod:prod:INFO/0:  STARTUP_TID:07/25/2008 09:37:52] Linked by root on host=(AIX lion 2 5 000FA26D4C

      00) at Thu Apr 24 00:20:47 2008 in /usr/work/jerickso/cloverrel/cloverleaf/engine/main (build 2)

      [prod:prod:INFO/0:  STARTUP_TID:07/25/2008 09:37:52] FEATURE cl-pkg-cl hcilicmgrd 5.6 12-oct-2008 un

      counted 83155693F03B

      [prod:prod:INFO/0:  STARTUP_TID:07/25/2008 09:37:52]    HOSTID=f631f4c ck=107 category=testdev

      [prod:prod:INFO/0:  STARTUP_TID:07/25/2008 09:37:52] FEATURE cl-intfc-thread-182 hcilicmgrd 5.6 12-o

      ct-2008 uncounted BA854EA205A6

      [prod:prod:INFO/0:  STARTUP_TID:07/25/2008 09:37:52]    HOSTID=f631f4c ck=103 category=testdev

      [prod:prod:INFO/0:  STARTUP_TID:07/25/2008 09:37:52] FEATURE cl-mm-master hcilicmgrd 5.6 12-oct-2008

      uncounted 181750D8C9E1

      [prod:prod:INFO/0:  STARTUP_TID:07/25/2008 09:37:52]    HOSTID=f631f4c ck=144 category=testdev

      [prod:prod:INFO/0:  STARTUP_TID:07/25/2008 09:37:52] Started at Fri Jul 25 09:37:52 2008

      [prod:prod:INFO/0:  STARTUP_TID:07/25/2008 09:37:52] Engine process is 42942 on host mchsie5

      (we are still waiting…)

      In 5.3:

      [prod:prod:INFO/0:  STARTUP_TID] QDX(TM) Integration Services 5.3P Rev2

      [prod:prod:INFO/0:  STARTUP_TID] Linked by root on mako at Fri Nov 19 22:19:01 2004 in /work2/jerick

      so/cloverrel/cloverleaf/engine/main (build 1)

      [prod:prod:INFO/0:  STARTUP_TID] Started at Fri Jul 25 09:40:16 2008

      [prod:prod:INFO/0:  STARTUP_TID] Engine process is 86854 on host mchsie5

      [prod:prod:INFO/1: adt_anc4_cmd] Msg space limit is 0[prod:prod:INFO/0: adt_anc4_cmd] DiskQue Minimum # of Messages/que: 50

      [prod:prod:INFO/0: adt_anc4_cmd] DiskQue Virtual Memory percent:75.000000

      [prod:prod:INFO/0: adt_anc4_cmd] Applying EO config: ”

      [prod:prod:INFO/0:adt_anc4_xlate] Applying EO config: ”

      [prod:prod:INFO/0:    isqlabint] Applying EO config: ”

      (HL7_REPLY_GEN/isqlabint) HL7 replies will be generated.

      (HL7_REPLY_GEN/isqlabint) Sequence number checking disabled

      Thanks again…


    • #65218
      Charlie Bursell

      Looks like something you need to have Support take a look at.

      I assume the roots are on different boxes?  I would still suspect the Network setup for that box.

    • #65219
      Antonio Chennawi

      We had the same issue, and we fixed it by changing permissions for resolve.conf to 664.

    • #65220
      Dee Davis

      All, the /etc/resolv.conf file was the issue.  On our previous versions 5.3 — Cloverleaf used /etc/hosts.  We didn’t even have it on the box.

      Thank you for everyone’s input.


Viewing 5 reply threads
  • The forum ‘Cloverleaf’ is closed to new topics and replies.

Forum Statistics

Registered Users
Topic Tags