Can’t test XML with testingtool

Homepage Clovertech Forums Read Only Archives Cloverleaf Cloverleaf Can’t test XML with testingtool

  • Creator
  • #49755
    Robert Kersemakers

    Hi all,

    I’m having my first try at XML and am not getting anywhere (using CL 5.5 on HP-UX).

    We need to process an SAP IDoc. SAP can deliver an IDoc as XML and also has XML-schemas for all the different IDocs. So I thought this would be very straightforward.

    I extracted the specific schema (matmas05.xsd) and compiled it in CL. No problem: the schema compiled nicely. I then got an xml example for this schema (matmas05.xml) and tried to run it through the testingtool, but that didn’t work: the testing-tool did nothing…

    I then followed Charlie’s (and some other forum-members’) advice and tried to validate matmas05.xml by using XMLSpy. That didn’t work, because the xml wasn’t linked to the schema. XMLSpy created the link, and now the xml (matmas05_schema.xml) could be validated.

    But when I run this xml through the testing tool, still nothing happens. Process ‘hcixmltest’ is eating up all performance and if I wait long enough, the testingtool returns an error:


    Please Wait ……
    Command Issued: hcixmltest -a  -d 1 -f eof -p test5 matmas05 /hci/qdx5.5/integrator/upgrade/formats/xml/test5/matmas05_schema.xml
    Command output:

    [0:TEST] Exception caught by general handler
    [0:TEST] An error occured during parsing.

    Can anybody help me with this problem? I attached a rar with all mentioned files.

    Zuyderland Medisch Centrum; Heerlen/Sittard; The Netherlands

Viewing 2 reply threads
  • Author
    • #63451
      Femina Jaffer

      Hi Robert,

      I had issues with this as well, but not exactly the same error you had.  If you want, you could email me and I could send my xml and dtd file to you, so you can have an idea of the format.

      Apparently, our problem was that althought the xml file compiled successfully, our dtd format was still a bit off.  Once we fixed that, we were able to test in the testing tool.  Are you able to test in the route tester?


    • #63452
      Robert Kersemakers

      Hi Femina,

      No, I haven’t tested in the route tester. I first want to make sure that the XML is shown correctly in the xml-testing tool.

      Thanks for your offer of a working xml/dtd, but I already have some xsd/xml examples from the internet and these work just fine in the testing tool.

      So I am still wondering why the mentioned xsd/xml doesn’t work in the xml testing tool. The weird thing is that the xml validates just fine. I don’t know where to look next.

      Zuyderland Medisch Centrum; Heerlen/Sittard; The Netherlands

    • #63453
      Robert Kersemakers

      Hi all,

      I solved my own problem with the help of our resident Cloverleaf distributor (thanks Alexander!).

      In the SAP XML schema, a lot of occurrence indicators were set to a specific (high) value, like maxOccurs = “999” or “99999” or “10000”. We replaced all these maxOccurs values with “unbounded”. After compiling this new schema, I was able to run the (same) XML through the xml-testingtool: all fields were shown.

      I think Cloverleaf is actually going through all the repeating elements when a specific value is indicated for maxOccurs. But that is just a guess on my part; maybe someone can confirm/dispute this.

      Zuyderland Medisch Centrum; Heerlen/Sittard; The Netherlands

Viewing 2 reply threads
  • The forum ‘Cloverleaf’ is closed to new topics and replies.

Forum Statistics

Registered Users
Topic Tags