alert error in hcimonitord.log

Homepage Clovertech Forums Read Only Archives Cloverleaf Cloverleaf alert error in hcimonitord.log

  • Creator
    Topic
  • #49712
    Gary Atkinson
    Participant

    Ok, I just don’t get why I keep getting this following error in the hcimonitord.log when an alert fires:

    Code:


    [aler:aler:WARN/0:  hcimonitord:12/21/2007 08:16:08] Reloading config file ‘/qdx/quovadx/qdx5.5/integrator/clinical/Alerts/default.alrt’.
    [aler:aler:INFO/0:  hcimonitord:12/21/2007 08:16:08] New alert #0:
    {VALUE pvmf} {SOURCE {localhost }} {MODE actual} {WITH -1} {COMP {<= 25}} {FOR once} {WINDOW {* * * * * *}} {HOST {}} {ACTION {{exec {alert_mail gatkinson@bwmc.umms.org "Virtual MemoryAlert" "%A"}}}} [aler:aler:INFO/0:  hcimonitord:12/21/2007 08:16:08] can't read "HCISITEDIR": no such variable [aler:aler:INFO/0:  hcimonitord:12/21/2007 08:16:08] New alert #1: {VALUE df} {SOURCE {/qdx }} {MODE actual} {WITH -1} {COMP {>= 78}} {FOR once} {WINDOW {* * * * * *}} {HOST {}} {ACTION {{exec {$HCISITEDIR/cscripts/alert_mail “gatkinson@bwmc.umms.org; rweisser@bwmc.umms.org”  “QDX disk is 80% full – Check Immediately” “%A”}}}}
    [aler:aler:INFO/0:  hcimonitord:12/21/2007 08:16:08] can’t read “HCISITEDIR”: no such variable

    This is error I don’t understand : “can’t read “HCISITEDIR”: no such variable.”  I get this for all the entries in the alert file.

    When the alert fires I do get an email from hci.  I have the path to the script “alert_mail” in my path.  But, when I remove this part from “exec” in the alerts $HCISITEDIR/cscripts and replace with just “alert_mail”, I do not receive an email alert.  If I run the alert_mail script from the command line, I do get a email.  This is where I am confused.  I am missing something somehwere, but I just don’t see it.  We are on CLoverleaf version 5.5 rev1 on AIX 5.3 os.

Viewing 4 reply threads
  • Author
    Replies
    • #63234
      Michael Hertel
      Participant

      It must be execing from a tcl shell.

      Try $HciSiteDir instead.

    • #63235
      Gary Atkinson
      Participant

      I forgot to mention the script is a ksh script.  When using exec option in the alert set-up, does the hci username enivornmental variables get passed?

    • #63236
      Russ Ross
      Participant

      Gary Atkinson:

      I have witnessed the alerts invoked via the exec do pass the hci environment variables to a stand alone ksh script that it calls and $HCISITEDIR works just fine.

      Like Micheal Hertel already mention the same environment variable is called $HciSiteDir when referenced from within TCL.

      It might be the $HCISITEDIR variable that can’t be read is this one which is being referenced in your exec part of your following alert

          {ACTION {{exec {$HCISITEDIR/cscripts/alert_mail etc…

      I suspect this particular $HCISITEDIR is being referenced from with TCL and needs to be

          {ACTION {{exec {$HciSiteDir/cscripts/alert_mail etc…

      just like Micheal Hertel already suggested.

      I’m unclear if you already tried Micheal’s suggestion as spelled out in my above example because you keep talking about the ksh script that gets called and $HCISITEDIR works fine for me in my ksh scripts called from the alerts in this manner.

      Could you please let us know if trying $HciSiteDir like in my example and was mentioned by Micheal Hertel did not work for you?

      Oh yeah, another improtant thing – be sure to cycle the monitor deamon after making the alert configuration change to be sure your change got picked up right away.

      Here are the steps I use to cycle the monitor deamon just to be safe

          hcisitectl -k m

          hcisitectl  -s m -A “a=-cl ‘default.alrt'”

      We don’t want to give Murphy’s law an opportunity to laugh at us while we chase our tail in a perpetual circle.

      I hope that is not already happening to you.

      Russ Ross
      RussRoss318@gmail.com

    • #63237
      paul sorya
      Participant

      Hi Gary,

      When a shell environment variable is used in “exec” of alert configuration. Each time the monitor deamon is cycled, you will always see this frictional error message: “XXXX: no such variable”.  

      As you mentionned, despite this faultly message in monitord.log, you receive anyway an email when the alert fires.

      (after the alert is fired, look either in hcimonitord.log or monitord.err. I prefer hcimonitord.err)

      Unless you place your alert_mail script in the search paths, you cannot remove $HCISITEDIR/cscripts from “exec”.

      You cannot neither replace it with $HciSiteDir because environment variables are case sensitive.

      To find out your installation search path, run “env” from command line and look for “PATH”.

      What I did, is using /home/hci/bin to keep my scripts, since it is in my search path. (you may need to create subdirectory bin under /home/hci).

      I keep only one copy of my shell script for all sites.

      I use also ksh script in exec option of my alert set-up and I have no problem with any environment variables.

      To prove this simply place “env > enviro.txt” in your script and, when the alert fires, look at the output enviro.txt in $HCISITEDIR/exec/hcimonitord/.

      (where $HCISITEDIR is the site path in which the alert is just fired). Later, do not forget to remove “env > enviro.txt” from your script.

      Hope this helps.

      Thanks!

      Paul Sorya

      Systems Analyst

      MD Center of Univerty of Montreal

      Canada

    • #63238
      Gary Atkinson
      Participant

      Thank you all for these ideas and tips.  I can live with errors for now since I am getting the emails when an alert is triggered  😉

Viewing 4 reply threads
  • The forum ‘Cloverleaf’ is closed to new topics and replies.

Forum Statistics

Registered Users
4,966
Forums
28
Topics
9,106
Replies
33,627
Topic Tags
248