5.5 fileset-ftp error

Homepage Clovertech Forums Read Only Archives Cloverleaf Cloverleaf 5.5 fileset-ftp error

  • Creator
    Topic
  • #49629
    Roger Moss
    Participant

    We just upgraded from 5.3 to 5.5 and are seeing the following error on outbound threads which use fileset-ftp for outbound FTP:

    [fset:wrte:ERR /0:  MedMined_ob:11/05/2007 16:50:25] Error while trying to write .

                            Detailed error:Uploading to a URL without a file name!

                              Curl errCode:3 Curl error: URL using bad/illegal format or missing URL

    I’m surprised that Curl is being invoked at all since these threads are not configured for secure FTP. We’re setting OBFILE in DRIVERCTL and I’ve tried all variations  for the file name concerning the forward slash, back slash and always get the same error, so it doesn’t seem to be related to that. Anyone come across this?

    Thanks, Roger

Viewing 6 reply threads
  • Author
    Replies
    • #62782
      Roger Moss
      Participant

      I was able to go back and spend some quality time on this problem and it turns out it was an issue with the backslash usage with cURL. I had to be specific with the pathing and use the backslash. 5.3 versions and before did not require this and the pathing was defaulting or getting set from the remote login if this was all you needed. This not longer appears to occur.

      On a side note with our upgrade to 5.5Rev1 -AIX 5.2. We are very pleased so far with this release. We have our CPUs back! We were on 5.3 and the Hostserver was holding our Box hostage. We could only run just a few clients concurrently without it having a huge impact on cycles and memory. Now we see none of that. We are able to run many now with little to no impact. The SMAT load times are much improved also. We did see a change in the Concat function within the Xlate tool that we had to adjust to. So far that has been it.   Kudos to Quovadx for what appears to be a much improved release.

    • #62783
      Bob Schmid
      Participant

      did you do this in the Netconfig or in an outbound tps….not quite clear.

      We are having the same problem….and not sure where and how exactly you tackled this.

    • #62784
      Bob Schmid
      Participant

      We put a “\” in the protocol defintion of the outbound file name.

      This solved our problem. 😀

      Roger wins the $million$  😉

    • #62785
      Bala Pisupati
      Participant

      Hi Robert

      we just upgrade to 5.5. and I have similar problem like Roger and for one of the threads the solution was also like his I specified the directory and it worked fine. But I have a different senario where say i need to ftp it to /opt/quovadx/qdx5.5/integrator/proda/data. I was wondering how I can use \ in this case.

      -Bala

    • #62786
      Bob Schmid
      Participant

      Here’s what we did:

      Turn up EO on the offending thread and see what path is getting built by the remote FTP server. ….you then can make the appropriate addition in your Clovereaf Fileset protocol def.

      What we did:

      In our “outbound directory” field under protocol fileset options we added “\” because the remote ftp server had a relative path and it needed the “” at the beginning.

    • #62787
      Bala Pisupati
      Participant

      Thanks Robert I will try and see.

    • #62788
      Bala Pisupati
      Participant

      It didn’t work, thanks anyway.

Viewing 6 reply threads
  • The forum ‘Cloverleaf’ is closed to new topics and replies.

Forum Statistics

Registered Users
4,966
Forums
28
Topics
9,105
Replies
33,625
Topic Tags
248